AnsweredAssumed Answered

HCI 1.1.4 Metrics Service not deploying

Question asked by Clifford Grimm on Feb 14, 2018
Latest reply on Feb 14, 2018 by Clifford Grimm

Trying to deploy an HCI system, and the Metrics service is not deploying and stuck at stage 1.  Also, I am in a dark site, so can’t get the logs and such.

 

The configuration is the following:

 

OS: Redhat 7.3

HCI: 1.1.4  (NOTE: Cannot install 1.2 version that likely resolves this)

Number Nodes: 4

Node Config:

   16GB memory

   4 CPU cores

   Only one NIC

Docker Info:

    Version: 1.12.6

    Storage Driver: devicemapper

    Backing FS: xfs

    Base Device Size: 10.74 GB

 

I have seen a bunch of postings related to this topic, and have tried a few things, but before I begin here is some observations:

 

  1. There is no elastic search in ps or docker ps.
  2. There are no log files in log/elastic-search, just an empty directory
  3. There are no files under hci/data/elastic-service/elastic-search/nodes/
  4. The svcbin/elastic-service/elastic.sh file did have references to _non_loopback.

 

Through the other postings, seems that much does not apply, as log files mentioned don’t exist, nor is there any processes/containers running.

 

I did try to modify the elastic.sh script as outlined, but still nothing started.

 

Quick look at watchdog logs, did not see any obvious indicators that it was even trying to start the elastic-search service.

 

What else can be done about debugging/resolving this issue?  Is it possible to try and start it manually to see what kind of output is generated?  Any ideas much appreciated!!

 

I haven't tried disabling IPv6, as it seemed like a long shot.

Outcomes