AnsweredAssumed Answered

HCI Plugins / configuration file issue for Stage Plugin

Question asked by Chris Delezenski Employee on Jul 27, 2017
Latest reply on Jul 27, 2017 by Chris Delezenski

Hello Community...


I'm working on the hornet project (OCR for HCI as a stage).


I have the OCR microservice (external to HCI) working properly.


I have a configuration file where I can define the URL of the microservice, but, for whatever reason, the config data won't populate.  I can't move forward without hardcoding the URL (really don't want to do that!)


"propertyGroups": [


            "name": "group",

            "type": "DEFAULT",

            "configProperties": [


                "name": "microservicePath",

                "type": "TEXT",

                "userVisibleName": "url for the microservice",

                "userVisibleDescription": "URL for the microservice, eg:",

                "options": [],

                "required": true,

                "value": "http://localhost/tifpdf/?toPDF&serialNumber=SWAT-xxx-xxx-xxx"



                "name": "debug",

                "type": "CHECKBOX",

                "userVisibleName": "debug",

                "userVisibleDescription": "This is an example checkbox property (debug mode).",

                "options": [],

                "required": false,

                "value": "true"






Any hints or tips as to where I'm going wrong... please let me know.


The configuration file was generated and otherwise generates no errors.


Thanks in advance!


Added source... whoops